You are here

issue

Title Body Tags
composer install problem with Currency module

command

$ sudo drush composer-manager update

error

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package bartfeenstra/currency could not be found in any version, there may be a typo in the package name.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see  for more details.

ファイルを編集。

$ sudo vim ./sites/all/modules/currency/currency/composer.json

"bartfeenstra/currency": "~1.0" を "bartfeenstra/currency": "dev-master"に変更。

Currency, composer
Composer アップデート時の RuntimeException

Composer をアップデートしようとすると、下記のエラーメッセージ。

$ sudo drush composer-manager update 
  [RuntimeException]
  Could not load package symfony/symfony in http://packagist.org: [UnexpectedValueException] Could not parse version constraint ^1.0.7: Invalid version strin
  g "^1.0.7"

これは、drushが使用しているComposer が古いため。composer.jsonファイルを修正してアップデートすればよい。

$ cd ~/.drush/composer/
$ sed -ie "s/1.0.0-alpha[1-9]/dev-master/g"  composer.json
$ composer update
composer